Добро пожаловать

1ExAlgo - это универсальный комплекс для работы с любыми типами торговых роботов, тестирования и управления ими.
Внутри 1ExAlgo Вы найдете:
  • 1.
    Около 100 бесплатных робота сразу на платформе. Посмотреть весь список
  • 2.
    Разработка роботов по Вашей логике или можно сделать робота самостоятельно.
  • 3.
    Бесплатное использование программы в течении 2х недель;
  • 4.
    Одновременная торговля по нескольким счетам;
  • 5.
    Одновременная работа нескольких десятков или сотен роботов;
  • 6.
    Скорость обработки алгоритма одного робота от 0,2 мсек;
  • 7.
    Тест работы алгоритма на исторических данных и подбор оптимальных параметров для каждого инструмента;
  • 8.
    И это далеко не все возможности платформы!
Подключай 1ExAlgo к своей любимой платформе
и, конечно, с самыми популярным криптобиржам (список постоянно пополняется)
А ещё 1ExAlgo - это встроенные модули для профессиональной торговли (нажми и узнай подробнее о каждом модуле)
Системные требования
  • •
    Процессор не хуже Pentium 4 (2.0 ГГц),
  • •
    Оперативная память не менее 4 ГБ (рекомендуется 8 ГБ),
  • •
    15 ГБ свободного места на жёстком диске,
  • •
    Операционная система Windows 10, Windows Server 2016, 2019 и выше,
  • •
    64-битная система,
  • •
    Под Windows 7 система работает, кроме возможности подключения к криптобиржам,
  • •
    Компонент Microsoft NET6 (бесплатно можно скачать с официального сайта Microsoft).


Как это работает

Всего 5 шагов и Вы торгуете и зарабатываете с роботами 1ExAlgo..
  • 1.
    Установка
  • 2.
    Регистрация и авторизация
  • 3.
    Подключение
  • 4.
    Выбор стратегии
  • 5.
    Тестирование
и вот теперь можно запускать боевую торговлю!
Но сначала гайд по интерфейсу..


Гайд по интерфейсу

1. Версия и тариф. Узнай больше о тарифах
2. Основное меню.
  • •
    Соединения
  • •
    Инструменты
  • •
    Модули
  • •
    Таблицы
  • •
    Настройки
  • •
    Справка
3. Вкладки, все открытые окно находятся во вкладках.
4. Общее меню кнопок работы с роботами, модулями и иными страницами платформы ( в зависимости от открытой страницы отличаются).
5. Список роботов. В частности на изображении открыт робот MA, в нем создано много роботов (это список, который мы видим), два робота запущены и торгуют.
6. График по выбранному роботу (на изображении идут котировки по выбранному инструменту (ETH/BUSD)).
7. Окно данных по торговле, здесь свои вкладки (открытые позиции, журнал, трейды, статистика за день, трейды эмуляции).


Регистрация и авторизация

×

  • Регистрация и авторизация
  • Предыдущая
  • Следующая
Регистрация и авторизация
Для прохождения регистрации, необходимо заполнить почту, которая еще не использовалась для регистрации программы и нажать кнопку "Зарегистрироваться". Если окно регистрации закрылось нажмите в верхнем меню "Соединение/Регистрация/Авторизация".
После этого на почту придет пароль, необходимы для авторизации. Данная пара, логин и пароль будут использовать для авторизации при каждом запуске 1ExAlgo. После ввода пароля, необходимо нажать кнопку "Авторизоваться". После прохождения авторизации, указанные ранее ограничения будут сняты, а если запуск идет в первый раз, то активируется демо доступ на 14 дней, он дает все возможности тарифа Pro, т.е. все возможности программы.
В шапке программы 1ExAlgo отобразится ваш E-mail и текущий тариф.
Если необходимо активировать лицензию, то необходимо вызвать меню "Настройки/Управление лицензиями" и ввести код активации.

Содержание Регистрация и авторизация

Установка


Установка

×

  • Регистрация и авторизация
  • Установка
  • Предыдущая
  • Следующая
Установка
Скачайте последнюю версию платформы с главной страницы сайта 1exalgo.com и запустите файл 1exalgosetup.exe.
Нажимаем кнопку "Далее"
Отмечаем (Выбираем) "Я принимаю условия соглашения", нажимаем кнопку "Далее"
Выбираем папку куда будет установлена программа, нажимаем кнопку "Далее"
Нажимаем кнопку "Далее"
(При необходимости создаем значок на Рабочем столе) Нажимаем кнопку "Далее"
Нажимаем кнопку "Установить"


Выбор подключения

×

  • Выбор подключения
  • Предыдущая
  • Следующая
Выбор подключения
В зависимости от того где Вы торгуете - выбираете подключение.
QUIK, TransaqConnector, IbTws - уже должны быть установлены и открыты счета, в этом Вам в помощь Ваш брокер.
Криптобиржи - должен быть открыт личный кабинет, т.е. пройдены все необходимые для конкретной биржи верификации.

Содержание Выбор подключения

Подключение к QUIK
Настройка TransaqConnector
Настройка IbTws
Подключение криптобиржи


Подключение к QUIK

×

  • Выбор подключения
  • Подключение к QUIK
  • Предыдущая
  • Следующая
Подключение к QUIK
Создание подключение в 1ExAlgo:
1. Торговый терминал Quik, к которому планируется подключения, должен быть выключен. После запуска 1ExAlgo необходимо перейти в пункт меню "Соединение"/ "Терминалы"
2. В боковом меню выбираем тип терминала Quik, появится окно "Добавления подключения и настройка Quik" (одновременно программа может работать с 10 Quik и неограниченным количеством счетов).
Если количество Quik'ов одновременно подключаемых более 1, то для оптимизации получаемой информации, рекомендуется только в одном Quik оставить "Таблицу текущих параметров" и "Таблицу всех сделок", в остальных Quik'ах ее закрыть.
3. Папку с файлом рабочих окон можно сразу открыть, его необходимо будет загрузить в Quik после установки соединения. Для подключения Quik, нужно указать путь до папки, где расположен файл info.exe. Если путь указан верно, то после указания пути до терминала станет активной кнопка "Установить настройки".
4. После этого запускаем Quik. Переходим в меню "Система" / "Загрузить настройки из файла", выбираем шаблон настроек (располагается в папке, куда установлена 1ExAlgo (..\1ExAlgo\Setting for terminals или данная папка была открыта из меню ранее ) и нажимаем Загрузить, и к настройкам добавятся дополнительные таблицы на отдельной вкладке. Если все сделано правильно в Quik появится новая вкладка под названием «1ExAlgo. Не меняйте формат таблиц на этой вкладке».
Важно! Программа получает только лишь ту информацию, которая передается из терминала. Поэтому в "Таблицу текущих параметров" необходимо добавить те инструменты, которыми будет вестись торговля. Также необходимо добавить информацию в "Таблицу всех сделок" по этим же инструментам. Если не строится тиковый график, то и не будут поступать данные в таблицу всех сделок. В этом случае необходимо обратиться к вашему брокеру и попросить чтоб он подключил тиковые графики. А еще не забудьте поменять в квике темную на светлую тему через меню Система/Настройки/Основные/Программа/Тема оформления.


Настройка TransaqConnector

×

  • Выбор подключения
  • Настройка TransaqConnector
  • Предыдущая
  • Следующая
Настройка TransaqConnector
Доступ к TransaqConnector, предоставляется брокером. Подключить его можно через личный кабинет.
1. В 1ExAlgo пункт меню "Настройки/Терминалы". Далее тип терминала выбираем TransaqConnector.
2. Добавить новый терминал.
Наименование | Описание
Название | Необязательное поле. Можно завести информацию откуда взят IP и другую полезную для пользователя информацию об IP.
IP адрес | По умолчанию.
Порт | По умолчанию.
Логин | Заполнять не обязательно, можно будет их заполнить при подключении.
Пароль | Заполнять не обязательно, можно будет их заполнить при подключении.
Параметры торговых серверов АО «Финам»
Основной адрес: tr1.finam.ru, порт: 3900;
Резервный адрес: tr2.finam.ru, порт: 3900.
Параметры торговых серверов АО «Банк Финам»
Основной адрес: tr1.finambank.ru, порт: 3324.
Резервный адрес: tr2.finambank.ru, порт: 3324
Важно! Если подключение к TransaqConnector осуществлено впервые, и раньше вы через него не торговали, то для совершения операций нужно будет сменить логин и пароль через программу после установление соединения.


Настройка IbTws

×

  • Выбор подключения
  • Настройка IbTws
  • Предыдущая
  • Следующая
Настройка IbTws
1. В терминале Ib Tws заходим в меню Файл / Глобальная конфигурация.
2. В открывшемся окне:
- раздел API / Настройки.
- Активировать ActiveX и сокет-клиенты - галочка должна быть установлена;
- Api, только чтение - галочка должна быть снята;
- Сокет-порт 7497 - должен совпадать с настройками в 1ExAlgo.
3. Настройки в 1ExAlgo: раздел Соединение/Терминалы и в открывшемся окне - "плюс" и выбрать IbTws.
4. Окно "Добавить новый терминал".
5. - добавить интересуемый инструмент..
Наименование
Описание
Код инструмента
Код инструмента в BTWS. Для фьючерсов необходимо указать только две буквы.
Тип инструмента
STK - акции, FUT - фьючерсы.
Валюта
Денежная единица, в которой рассчитывается инструмент.
Primary Exchange
Основная площадка с которой идет получение котировок по инструменту.
Exchange
По умолчанию можно ставит SMART или написать ту же площадку что Primary Exchange.
Множитель
Необязательное поле, но для некоторых инструментов, ели у них одинаковый тикер требуется указать множитель - Multiplier.
Шаг цены
Для правильного расчета, необходимо указать минимальный шаг инструмента.
Дата экспирации
Дата исполнения фьючерса или опциона.
ГО
Гарантийное обеспечение для фьючерса или опциона.
Котировка
Price Quotation. Данное поле заполняется, если фьючерсный или другой контракт имеет нестандартное вычисление стоимости и неполную шкалу по цене (пример по ZB 148000-148320, далее еще повышение на один так даст котировку 149000).
Пример: Контракт ZB - Points ($1,000) and 1/32 f a point. For example, 134-16 represents 134 16/32. Par is on the basis of 100 points. В этом случае выбирается 1/32.
6. После настройки инструментов и торгового терминала, нажимаете Соединения/Установить соединение.


Подключение криптобиржи

×

  • Выбор подключения
  • Подключение криптобиржи
  • Предыдущая
  • Следующая
Подключение криптобиржи
Процесс подключения к любой криптобирже одинаковый.
1. В 1ExAlgo: Соединение/Терминалы и выбираем нужную криптобиржу.
2. Настройка параметров подключения.
3. Далее необходимо ввести публичный ключ и секретный ключ. Создать их можно на своем аккаунте криптобиржи.
4. Выбираем режим работы коннектора. Режим “Публичный” – не требует ключей, можно написать любые данные, т.е. будут поступать данные, которые предоставляет биржа (Стакан, Лента сделок, Котировки по парам, исторические данные).
При необходимости совершить операцию, нужно будет выбрать режим “Приватный” и ввести действующие ключи.
5. Добавляем, отмечая галочкой, необходимые инструменты - переносятся слева на право.
6. Нажимаете Соединение/Установить соединение, статус соединения изменится на зеленый.


Выбор робота

Робот - это автоматизированная стратегия. Выберите своего робота или торгуйте сразу несколькими.
Не знаете с какой стратегии начать? Начните лучше с простых роботов, по типу МА - Скользящая средняя, изучите как она работает, в 1ExAlgo напротив каждой стратегии есть ссылка на информацию по данной стратегии.
  • 1.
    ADX50
  • 2.
    AdxMa
  • 3.
    AdxTS
  • 4.
    Alligator
  • 5.
    Arbitrage
  • 6.
    ArbitrageV2
  • 7.
    AvgVolume
  • 8.
    BbOpenClose (Полосы Боллинджера)
  • 9.
    BbOpenClose2 (Полосы Боллинджера 2)
  • 10.
    BbOpenCloseRevers (Полосы Боллинджера реверс)
  • 11.
    BbOpenCloseRevers2 (Полосы Боллинджера реверс 2)
  • 12.
    BbOpenProboyRevers (Полосы Боллинджера пробой реверс)
  • 13.
    BbProboy (Полосы Боллинджера пробой)
  • 14.
    BbProboy2 (Полосы Боллинджера пробой 2)
  • 15.
    BollingerRsi
  • 16.
    BullishHarami (Бычье харами)
  • 17.
    CandleRobot (Робот по свечам)
  • 18.
    CandleRobot2 (Три свечи подряд)
  • 19.
    CciDivergence
  • 20.
    CCIStochMa
  • 21.
    ChaikinVolatility (Волатильность Чайкина)
  • 22.
    DarkCloudCover
  • 23.
    DoubleChannel
  • 24.
    EldersScreens
  • 25.
    EnvelopesClose (Конверты)
  • 26.
    EnvelopesOpenClose2 (Конверты 2)
  • 27.
    EnvelopesOpenClose3 (Конверты 3)
  • 28.
    Fibo
  • 29.
    FractalChannel (Фрактальный канал)
  • 30.
    FractalChannelOneOpen (Фрактал один вход)
  • 31.
    GravestoneDoji
  • 32.
    Guide
  • 33.
    Hammer
  • 34.
    HangingMan
  • 35.
    HorizonalLevel (Горизонтальные уровни)
  • 36.
    HorizonalLevelCandle (Горизонтальные уровни с графиком)
  • 37.
    HorizonalLevelOtboy (Горизонтальные уровни отбой)
  • 38.
    Levels (Уровни)
  • 39.
    LindaRashke
  • 40.
    LongLeggedDoji
  • 41.
    MA (Скользящие средние)
  • 42.
    MA2 (4 Скользящие средние)
  • 43.
    MA4 (Скользящие средние 4)
  • 44.
    MAandMacd
  • 45.
    MaAndPrice (Скользящая средняя и цена)
  • 46.
    MaAndPriceRevers (Скользящая средняя и цена. Реверс.)
  • 47.
    MacdAo
  • 48.
    MacdChange
  • 49.
    MacdDivergence (Macd дивергенция)
  • 50.
    MacdEma
  • 51.
    MacdHistChange
  • 52.
    MacdHistLevel
  • 53.
    MacdLevel (Macd уровень)
  • 54.
    MacdRobot (Робот по индикатору MACD)
  • 55.
    MacdSar
  • 56.
    Martingail
  • 57.
    MartingailV2
  • 58.
    MMF (Скользящие средние и фрактал)
  • 59.
    OneTwoThree
  • 60.
    ParabolicSarRsi
  • 61.
    PercentChange
  • 62.
    PinBar
  • 63.
    PirceChannelOtboy (Отбой канала)
  • 64.
    PirceChannel Proboy (Пробой канала)
  • 65.
    PirceChannel Proboy2 (Пробой канала 2)
  • 66.
    PirceChannel Proboy3 (Пробой канала 3)
  • 67.
    PirceChannel Proboy4 (Пробой канала 4)
  • 68.
    PirceChannel_Proboy5Close (Пробой канала по закрытию)
  • 69.
    PrevDayClose
  • 70.
    Renko
  • 71.
    RisingThreeMethods
  • 72.
    RsiDivergence (RSI дивергенция)
  • 73.
    RsiRobot (Робот по индикатору RSI)
  • 74.
    RsiSarRobot (RSI + фильтр SAR)
  • 75.
    RsiSarRobot2 (RSI + фильтр SAR 2)
  • 76.
    SarRobot (Параболик SAR)
  • 77.
    SarRobot2 (Параболик SAR 2)
  • 78.
    SarRobot2Profit (Робот SAR2 + Профит)
  • 79.
    SecondInstrSignal
  • 80.
    StochasticAdxMa
  • 81.
    StochasticCross (Стохастик пересечение)
  • 82.
    StochasticCrossAndLevel (Стохастик пересечение и уровень)
  • 83.
    StochasticCrossAndLevelProboy (Стохастик пересечение и пробой)
  • 84.
    StochasticLevel (Стохастик и зоны)
  • 85.
    ThreeWhiteSoldiers
  • 86.
    TrendMomentum
  • 87.
    TrendNRTR
  • 88.
    Triangle
  • 89.
    VolCandle
  • 90.
    WillamR1Cross (WillamR пересечение)
  • 91.
    WilliamsSar

Содержание Выбор робота

Работа с роботами
Внутрянка робота


Работа с роботами

Определились со стратегией? Тогда пришло время запустить своего первого робота!
Через раздел "стратегии" загружаются, удаляются, и запускаются новые роботы в 1ExAlgo. Достаточно просто кликнуть по необходимой стратегии, подтвердить действия и Вы попадете во вкладку стратегии.
Количество стратегий и роботов с различными параметрами настроек, торгуемыми инструментами и счетами, можно создать и запустить любое количество (ограничения имеются в зависимости от типа лицензии на 1ExAlgo). Чем больше роботов одновременно запущено и тем сложнее алгоритм, тем больше времени требуется для обработки информации. В зависимости от мощности компьютера, сложности стратегии и количества роботов, время затрачиваемое на обработку всех роботов по запущенной стратегии будет разное и оно отображается слева от кнопки [image] в миллисекундах. Среднее время обработки алгоритма робота 0,2-0,4 миллисекунды, в зависимости от мощности компьютера и сложности алгоритма.
- загрузка стратегии, сканера, портфельного скрипта или пользовательской статистики (файл с расширением cs), в выбранную директорию или через контекстное меню. Сканеры, портфельные скрипты и пользовательская статистика автоматически перемещаются в соответствующую папку. Подробнее о процедуре загрузки стратегии описано в разделе "Загрузка и удаление стратегий";
- удалить выделению скрипт;
- протестировать выделенную стратегию;
- запустить выделенную стратегию;
- создать контейнер стратегии (для передачи стратегии другому лицу, с закрытым кодом);
- загрузить контейнер стратегии.
- Нажмите если требуется запустить робота, в данном положении тумблера робот отключен, нажимайте на этот тумблер напротив каждого робота, которого необходимо запустить.
- Цвет кнопки меняется на зелёный как меняется статус запускаемого робота. И как только появиться информация в столбцах "Цена" и "Посл. изм.", то начнется торговля. Для остановки робота необходимо нажать на зелёную кнопку повторно.
- Нажмите для запуска сразу всех роботов.
- Нажмите для остановки всех роботов.
1. Список роботов. Список представлен в виде таблице. В таблице может быть до 15 колонок, их можно настраивать под себя, сами колонки представляют параметры настроек выбранные в роботе и показатели.
2. Таблица переменные и значения. Таблица расположена справа от списка роботов по запущенной стратегии. В данную область можно выводить дополнительную информацию из кода робота, например, расчет какой-либо переменной или значение. Для удобства в таблице есть вкладка график.
3. Информация по торговле. Для визуального контроля работы роботов представлены: Открытые позиции, журнал, сделки, статистика за день, сделки эмуляции.


Внутрянка робота

×

  • Выбор робота
  • Внутрянка робота
  • Предыдущая
  • Следующая
Внутрянка робота
Внутри любого робота мы увидим вкладки:
  • •
    Основные настройки (счет, инструмент, размер позиции, таймфрейм);
  • •
    Робот и\или Индикаторы (настройки стратегии робота);
  • •
    Сервис (дополнительные тонкие плюшки по настройке);
  • •
    Стоп-заявки (стоп-лимит, профит, трейлинг профит и др.);
  • •
    Риски (встроенный риск менеджер);
  • •
    Время (управление временем работы).

Содержание Внутрянка робота

Основные настройки
Робот и индикаторы
Стоп-заявки
Риски
Время


Основные настройки

Рекомендуется. При первичном знакомстве с роботом и его настройками, рекомендуется выбрать виртуальный режим торговли. При первом запуске робота в реальном режиме торгов, рекомендуется использовать либо демо счет (для понятия как торгует робот и проверки правильности настроек) или, если счет "боевой", то рекомендуется выставить размер позиции фиксированный, равный 1 контракту/лота. После того как вы освоились с управлением, можно будет переходить на "нормальный" режим торгов, с вашими настройками.
Заполняем основные данные по роботу
Название - выбери любое название для своего робота
Счет - именно на нем будет вестись торговля
Режим торгов: Виртуальный режим - робот эмитирует реальную торговлю (торгуешь - учишься - не тратишь деньги), Реальный - он же боевой режим, с отправкой приказов на биржу.
Тип торговли - выбор направления торговли. "Лонг и Шорт" - робот открывает длинную и короткие позиции.
Инструмент - код инструмента, по которому будет вестись торговля.
Класс - код класса инструмента, торговый раздел, в котором находится инструмент.
Размер позиции Количество контрактов/лотов, которыми будет открывать позицию робот определяется в зависимости от настроек "Размера позиции". Тут выставляется и источник депозита, и начальный депозит и другие значения.
Таймфрейм - период интервала. Возможные варианты: тики, секунды, минуты, дни, недели и месяцы.


Робот и индикаторы

Во вкладку "робот" выводятся переменные, которые может изменять пользователь. Количество и типы настраиваемых параметров зависит от разработчика торгового алгоритма, если же ни одного параметра для настройки не будет, то данная вкладка не будет отображаться.
Если в торговле используется индикаторы заложенные в 1ExAlgo по умолчанию, то на этой вкладке можно будет его настроить. Если индикаторы не используется в роботе, то данная вкладка будет отсутствовать.
Каждый робот уникален, изучите, как работает стратегия, выбранного Вами робота, поэкспериментируйте с настройками в виртуальном режиме, посмотрите на , что влияет изменение того или иного параметра в роботе.


Стоп-заявки

Типы стоп-заявок:
  • •
    Стоп-лимит - используется стоп-заявка для фиксации потерь. Если цена изменится в сторону убытка на заданную величину, то позиция закроется.
  • •
    Профит (лимитная заявка) - используется лимитная заявка для фиксации прибыли, в случае использовании виртуального профита, стоит учесть следующее. Условия срабатывания заявки например +10 пунктов от цены открытия сделки, как только цена будет +10 пунктов, в торговый терминал отправиться заявка. Если заявка рыночная, то будет исполнение по цене спроса (например лучшие цены спроса и предложения в стакане 120 и 130. Закрытие длинной позиции будет по цене 120, т.е. фактически, условия выполнены, а прибыли в этом случае не получена из-за большого спреда в стакане).
  • •
    Стоп-лимит и профит - используются стоп-лимит и профит (лимитная заявка)
  • •
    Треллинг-профит - возможность дать прибыли расти и в случае отклонения от максимального значения прибыли в сделки на заданную величину и закрыть позицию.
  • •
    Треллинг-профит и стоп-лимит - используется стоп-лимит и треллинг-профит.
Пример работы стоп-лимит
Исходные данные: Отступ=30, Спред=5, Цена расчета - цена сигнала.
Открытие позиции было по цене 57288, от этой цены рассчитывается значение цены на которой будет стоять стоп-заявка: цена стоп-заявки = цена открытия позиции - отступ * минимальный шаг цены=57288-30*1=57258. При активации стоп-заявки, заявка на биржу будет выставлена по цене 57258-спред * минимальный шаг цены=57258-5*1=57253, а исполнение ее будет по лучшей цене на рынке. Если спред "маленький" или рынок сильно волатильный, то заявка может остаться стоять в стакане.


Риски

Встроенный в каждого робота Риск-менеджер. Для каждого робота можно задать свои ограничения по рискам на день, при достижении которых он прекратит торговлю до конца дня или на указанную паузу. Добавляет спокойствия в торговлю, с установленными настройками рисков, можно спокойно оставлять робота торговать без Вашего контроля, зная, что он, например не сольет депозит, а остановится при определенном минусовом значении.
Тип риска
Прибыль - При достижении указанной прибыли дальнейшая торговля на сегодняшний день будет запрещена. Закрывает все позиции и по возможности снимает все заявки и стоп-заявки. Если данная величина равна нулю, то не участвует в расчетах
Просадка - При достижении указанного убытка дальнейшая торговля на сегодняшний день будет запрещена. Закрывает все позиции и по возможности снимает все заявки и стоп-заявки. Если данная величина равна нулю, то не участвует в расчетах
Треллинг профит - Предназначен для сохранения прибыли. Пример: Активация 5000 рублей, отступ 1500 рублей, треллинг профит начнет действовать, когда прибыль достигнет отметки в 5000 рублей, то от этой величины начинает отсчитывается отступ и прекращение торговли произойдёт на отметке 3500 рублей. Если же будет достигнут новый максимум по прибыли, то расчет будет вестись от него, т.е. достигнута прибыль 5500 рублей, то прекращение торгов произойдет на отметке 4000 рублей.
Защита прибыли - Предназначена для защиты прибыли. Пример: Активация 3000 рублей, Уровень защиты 2000 рублей, защита начнет действовать, когда прибыль достигнет отметки в 3000 рублей и в случае уменьшения прибыли до 2000 рублей, торговля будет запрещена. В отличии от треллинга уровень защиты всегда будет находится на одном месте, после активации, какой бы не была полученная прибыль. В этом случае торговлю можно продолжать до тех пор, пока прибыль не уменьшится до 2000 рублей.
А также еще значения рисков..
Остаток на счете, прибыль зафиксированная, прибыль (Факт.), убыток, убыток зафиксированный, убыток (Факт.), треллинг-профит зафиксированный, треллинг-профит (Факт.), защита прибыли зафиксированная, защита прибыли (Факт.), количество сделок, количество убыточных сделок, убыточных сделок подряд, прибыльных сделок подряд.


Время

Настройки времени позволяют настроить работу робота в определенное время и дают возможность закрывать позиции по роботу перед окончанием сессии. Можно настроить время работы робота на каждый день индивидуально, или установить несколько временных интервалов торговли на один день.
Тип действия - что происходит при наступлении заказанного времени
  • •
    Открытие\Закрытие позиции
  • •
    Закрытие позиции
  • •
    Открытие позиции
  • •
    Снятие и принудительное закрытие


Выбор модуля

Модуль в 1ExAlgo - это может быть расширенная стратегия или вспомогательные торговые боты для обеспечения контроля безопасности и иных действий при торговле.
  • 1.
    Модуль

    "

    Автостопы

    "

    2. Модуль

    "

    Риск-менеджер

    "

    3. Модуль "Копировщика сделок"

Содержание Выбор модуля

Модуль Риск-менеджер


Модуль Риск-менеджер

Назначение:
Контроль убытков и защита прибыли, качество сделок и защита депозита при серии неудач – риск-менеджер ваш помощник в этом. Предназначен для личного самоконтроля, контроля рисков депозита под управлением и для управляющих группой трейдеров..
Возможности:
  • •
    Устанавливается на локальный компьютер трейдера или на выделенный сервер;
  • •
    Установление лимитов на каждый инструмент;
  • •
    Установка рисков по времени и дополнительных рисков (например, просадка до 14:00 - 5000 рублей, а до конца сессии - 15000);
  • •
    Установка комиссии отдельно на каждый инструмент и в целом по классу;
  • •
    Различные лимиты по сделкам (общее количество, количество убыточных и серия убыточных);
  • •
    Отображение статистики за день;
  • •
    Возможность установки защиты прибыли и треллинг профит;
  • •
    Установка минимального депозита по счету;
  • •
    Установка блокировки на определенный период времени (пауза в торговле);
  • •
    Возможность установки различных параметров блокировок;
  • •
    Разбивка убытков на несколько частей, например, для первой и второй половины торговой сессии.
  • •
    И многое другое.
    Для кого предназначена данная программа
  • •
    для тех, кто только начинает свою торговлю на рынке и не может контролировать убытки или уберечь свою прибыль;
  • •
    для опытных трейдеров, для личного самоконтроля или находящихся в тильте;
  • •
    для трейдеров кому трудно контролировать свои эмоции;
  • •
    для инвесторов предоставившие свои счета в управление трейдеру. Со стороны инвестора можно установить лимиты трейдеру на торговую сессию, чтоб он не терял больше оговоренной суммы и/или минимальный остаток по счету;
  • •
    для дилинговых залов, брокеров, управляющих компаний и их клиентов;
  • •
    для руководителей управляющих командой трейдеров. С помощью программы устанавливаются лимиты возможных потерь, на каждого из трейдеров и можно не беспокоиться, что в момент вашего отсутствия трейдер превысит установленные лимиты или нарушит правила.


Тестирование

В данном разделе возможно тестировать и оптимизировать стратегию на исторических данных. Если стратегия использует для анализа: цену последней сделки, сумму спроса и предложения или данные из стаканов, то такие стратегии можно протестировать только в режиме реального времени, либо в «автоматическом» режиме с реальным выставлением заявок на биржу или в виртуальном режиме - режим эмуляции сделок, без отправки их на биржу.
Стратегии, алгоритмы которых построены на анализе свечей, индикаторов, различных паттернов и условий возможно проанализировать (протестировать) на исторических данных, предварительно загрузив их в «Источники данных», либо на "Данных из хранилища" - история накопленная во время реальных торгов.

Содержание Тестирование

Источники данных
Запуск тестирования и результаты
Оптимизация


Источники данных

Источники данных используются для тестирования на истории и автоматической загрузке истории.
Инструменты\Источники данных. В левой части находятся созданные источники, рекомендуется чтобы в названии было таймфрейм и источник, откуда они были скачены. В правой части находится информация о месте расположения файлов.
Единоразовое скачивание или автоматическая загрузка исторических данных для тестирования производится в разделе поставщики данных. В левой части находятся Биржи и источники, с которых можно выгружать исторические данные.
Для загрузки данных, нужно через контекстное меню нажать "Загрузить данные".
Скачивание исторических данных
Скачать данные можно с различных ресурсов. В качестве примеров будет рассмотрено два примера сохранение данных из торгового терминала Quik и с сайта www.finam.ru .
Пример 1. Сохранение данных из торгового терминала Quik. В торговом терминале необходимо открыть график по интересующему инструменту, выбрать таймфрейм и на любой свече (баре) нажать правой кнопкой мыши и выбираем пункт "сохранить график". Данные сохраняются в текстовом формате, которые можно загрузить в источники данных.
Пример 2. Загрузка с сайта www.finam.ru. Переходим по ссылке http://www.finam.ru/profile/moex-akcii/gazprom/export/ выбираем нужный инструмент. Настраиваем период времени за который нужны данные и таймфрейм. После этого все поля приводим к формату удобному для вас или как на картинке ниже, но в любом случае разделитель разрядов должен быть выбран "нет" и нажимаем кнопку получить файл.
Загрузка данных с криптобиржи
  • 1.
    Соединиться с криптобиржей
  • 2.
    «Инструменты/ Источники данных».
  • 3.
    Либо через меню, либо через контекстное меню – пункт меню «Добавить»
  • 4.
    Выбираем интересующие инструменты, по которым нужно получить исторические данные и переносим в колонку торгуемых инструментов.
  • 5.
    Вводим название данного источника (название может быть любым, главное, чтобы было Вам понятно)
  • 6.
    Выбираем: Таймфрейм, период – за который будем загружать исторические данные и инструменты
  • 7.
    Остальное можно не менять.
  • 8.
    Через контекстное меню выбираем «Загрузить данные»


Запуск тестирования и результаты

×

  • Тестирование
  • Запуск тестирования и результаты
  • Предыдущая
  • Следующая
Запуск тестирования и результаты
Подготовка к тестированию
1. Выбираете стратегию для тестирования. Нажимаете [image] и делаете выбор. Вносите корректировки при необходимости в стратегию в Параметрах. В левой части раздела тестирования, выбираем инструмент, который планируется тестировать, он автоматически подставляется в робота.
2. Выбираете период тестирования
3. Выбираете данные для тестирования
4. Нажимаете на кнопку "Начать"
Результаты тестирования
График. Отображается график инструмента, по которому ведется тест, а также индикаторы и все дополнительные линии, которые разработчиком стратегии были предусмотрены для отображения на графике. Вместо времени графика в нижней части его расположена ось номеров свечей. Нумерация идет от 0 до текущей свечи на графике.

Статистика

Результирующая информация по торговли стратегии на исторических данных. В колонке «Все» - отображается информацию по всем сделками, в колонке «Покупки» - только информация по сделкам Лонг, в колонке «Продажи» - только информация по сделкам Шорт, в колонке «Купи и держи» - отображается информация о том, что было бы при одной сделке в начале тестируемого периода.
Сделки
По результатам тестирования в данном разделе появятся все сделки которые были совершены, а также подробная информация по ним.
Быстрый переход к сделке на графике: при двойном клике левой кнопкой мыши на сделке, откроется график, где самая левая сделка будет та, по которой вы сделали двойной клик.

Доходность и просадка

На графике доходность отображается рост и падение кривой капитала.
График просадки показывает максимальное уменьшение денежных средств по счету в процентах. В случае, если начальный капитал равен 0, то будет отображаться абсолютное значение, а если задан, то в процентах, относительно начального капитала.


Оптимизация

Оптимизация - это процесс подбора комплекта параметров с целью повышения эффективности (прибыльности и стабильности) результатов торговой системы.
В разделе оптимизации отображаются параметры стратегии, которые можно оптимизировать.
Кнопка "Начать оптимизацию" запускает процесс перебора параметров. По мере прогресса оптимизации появится окно "Результаты" рядом с окном "Оптимизация". В "Результаты" заносятся итоги тестирования системы. Двойной клик по интересующим результатам даст детальную статистику - автоматически подставит параметры в обычный тест и запустит тест.
Также можно использовать возможности продвинутой оптимизации:
  • •
    Добавление таймфрейма;
  • •
    Добавление инструмента;
  • •
    Использование скрипта статистики.


Еще множество возможностей

  • •
    Управление роботами
  • •
    Портфель роботов
  • •
    Контейнеры
  • •
    Уведомления
  • •
    Хранилище данных
  • •
    Портфельное тестирование
  • •
    Форвардное тестирование
  • •
    Открытый API